flutter_plugin_android_lifecycle 2.0.6 icon indicating copy to clipboard operation
flutter_plugin_android_lifecycle: ^2.0.6 copied to clipboard

PlatformAndroid

Flutter plugin for accessing an Android Lifecycle within other plugins.

2.0.6 #

  • Adds OS version support information to README.
  • Fixes library_private_types_in_public_api, sort_child_properties_last and use_key_in_widget_constructors lint warnings.

2.0.5 #

  • Updates compileSdkVersion to 31.

2.0.4 #

  • Updated Android lint settings.
  • Remove placeholder Dart file.

2.0.3 #

  • Remove references to the Android V1 embedding.

2.0.2 #

  • Migrate maven repo from jcenter to mavenCentral.

2.0.1 #

  • Make sure androidx.lifecycle.DefaultLifecycleObservable doesn't get shrunk away.

2.0.0 #

  • Bump Dart SDK for null-safety compatibility.
  • Fix outdated links across a number of markdown files (#3276)

1.0.12 #

  • Update Flutter SDK constraint.

1.0.11 #

  • Keep handling deprecated Android v1 classes for backward compatibility.

1.0.10 #

  • Update android compileSdkVersion to 29.

1.0.9 #

  • Let the no-op plugin implement the FlutterPlugin interface.

1.0.8 #

  • Post-v2 Android embedding cleanup.

1.0.7 #

1.0.6 #

  • Make the pedantic dev_dependency explicit.

1.0.5 #

  • Add notice in example this plugin only provides Android Lifecycle API.

1.0.4 #

  • Require Flutter SDK 1.12.13 or greater.
  • Change to avoid reflection.

1.0.3 #

  • Remove the deprecated author: field from pubspec.yaml
  • Require Flutter SDK 1.10.0 or greater.

1.0.2 #

1.0.1 #

  • Register the E2E plugin in the example app.

1.0.0 #

  • Introduces a FlutterLifecycleAdapter, which can be used by other plugins to obtain a Lifecycle reference from a FlutterPluginBinding.
65
likes
130
pub points
99%
popularity

Publisher

verified publisher iconflutter.dev

Flutter plugin for accessing an Android Lifecycle within other plugins.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_plugin_android_lifecycle