flutter_platform_storage 1.0.3+4

flutter_platform_storage #

A plugin to detect the platform on any platform

Why does this packages have such a low score? #

Unfortunately the analysis tool thinks you can't import dart:html in a flutter package, but it's needed.

[ 1.0.3+4] - 13th of July 2019

  • Add check if key is available

[ 1.0.2+3] - 8th of July 2019

  • Add support for direct JSON

[ 1.0.1+2] - 3rd of July 2019

  • Fix homepage URL

[ 1.0.0+1] - 3rd of July 2019

  • Plugin created

example/main.dart

/*
 Just a placeholder.
 Look at https://github.com/jld3103/ginko/app for an example.
 */

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_platform_storage: ^1.0.3+4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_platform_storage/flutter_platform_storage.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
31
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
26
Learn more about scoring.

We analyzed this package on Jul 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.3

Platforms

Detected platforms:

Error(s) prevent platform classification:

Error(s) in lib/flutter_platform_storage_web.dart: Target of URI doesn't exist: 'dart:html'.

Health issues and suggestions

Fix lib/flutter_platform_storage_web.dart. (-43.75 points)

Analysis of lib/flutter_platform_storage_web.dart failed with 2 errors:

line 4 col 8: Target of URI doesn't exist: 'dart:html'.

line 8 col 22: Undefined name 'window'.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Error(s) in lib/flutter_platform_storage_web.dart: Target of URI doesn't exist: 'dart:html'.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
flutter_platform ^1.0.2+3 1.0.2+3
shared_preferences ^0.5.3+1 0.5.3+4
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test

Admin