flutter_pgyer 1.0.0

flutter_pgyer #

pub package

支持Android/iOS 运营统计、原生异常上报、flutter异常上报、应用更新、用户反馈 #


1、引入 #

dependencies:
  flutter_pgyer: lastVersion

2、使用 #

import 'package:flutter_pgyer/flutter_pgyer.dart';

//使用flutter异常上报
void main() => FlutterPgyer.reportException(()=>runApp(MyApp()));

//初始化
FlutterPgyer.init(
        iOSAppId: "appid",
        androidAppId: "appid",
      });

//用户反馈附带参数
FlutterPgyer.setEnableFeedback(param: map);

//检查更新,android用户获取更新信息,iOS直接弹窗
//可选参数
//bool autoDownload = false, //android专用,自动下载安装,没有交互界面
FlutterPgyer.checkUpdate();

//获取更新信息
FlutterPgyer.getAppBean().then((appBean){
              print(appBean?.downloadURL);
            });

1.0.0 #

  • 实现异常上报(iOS/Android)
  • 实现内测分发应用更新(iOS/Android)
  • 支持自定义分发应用更新(Android)
  • 实现摇一摇反馈,并附带反馈自定义信息(iOS/Android)
  • 支持摇一摇反馈界面颜色主题定义(iOS/Android)

example/README.md

flutter_pgyer_example #

Demonstrates how to use the flutter_pgyer plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_pgyer: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_pgyer/flutter_pgyer.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
27
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
59
Learn more about scoring.

We analyzed this package on Aug 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/flutter_pgyer.dart.

Run flutter format to format lib/flutter_pgyer.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test