flutter_persist_http 0.0.2

  • Readme
  • Changelog
  • Installing
  • 43

flutter_persist_http #

package design for making your http request easy ,persist your http response and easy to parse respon (json )to model object.

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with flutter _persist_http, view our online documentation, which offers tutorials.

Let see feature of this package #

🔥Save your http api data
🔥Save your time required to parse json 🔥Saving list of map obj & single map obj Saving 🔥Your http Get method with returning objwhich can easily be parsed to flutter obj. 🔥Reduce boilerplate code of http 🔥Show data when user is offline 🔥HttpMap class for static method to parse your response directely to map obj & also thier are method which gives only response in case u want to apply condition to response and then u can simply

[0.0.1] - Initial release. #

  • Save your http request.
  • Parse your http request with dart
  • Get saved data of http request with dart

[0.0.2] - Some minor bug fixes. #

  • Easy to save dart
  • Some Minor bug fixes.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_persist_http: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_persist_http/flutter_persist_http.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
66
Overall:
Weighted score of the above. [more]
43
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • flutter_persist_http that is a package requiring null.

Package not compatible with runtime flutter-web on Web

Because:

  • package:flutter_persist_http/flutter_persist_http.dart that imports:
  • package:flutter_persist_http/src/persistHttp.dart that imports:
  • package:flutter_persist_http/src/persistApi.dart that imports:
  • dart:io

Health issues and suggestions

Document public APIs. (-1 points)

40 out of 40 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/flutter_persist_http.dart.

Run flutter format to format lib/flutter_persist_http.dart.

Format lib/src/exception.dart.

Run flutter format to format lib/src/exception.dart.

Format lib/src/method.dart.

Run flutter format to format lib/src/method.dart.

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/persist.dart (Run flutter format to format lib/src/persist.dart.)
  • lib/src/persistApi.dart (Run flutter format to format lib/src/persistApi.dart.)
  • lib/src/persistHttp.dart (Run flutter format to format lib/src/persistHttp.dart.)

Maintenance suggestions

The package description is too short. (-14 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_persist_http.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
http ^0.12.0+4 0.12.1
Transitive dependencies
charcode 1.1.3
collection 1.14.12 1.14.13
http_parser 3.1.4
meta 1.1.8 1.2.2
path 1.7.0
pedantic 1.9.0 1.9.2
sky_engine 0.0.99
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test