flutter_permissions 0.0.2+1

  • Readme
  • Changelog
  • Installing
  • 46

flutter_permissions #

flutter 权限申请

IOS 配置 #


<!-- 相册 -->
<!-- 相机 -->
<!-- 麦克风 -->
<!-- 位置 -->
<!-- 在使用期间访问位置 -->
<!-- 始终访问位置 -->
<!-- 日历 -->
<!-- 提醒事项 -->
<!-- 运动与健身 -->
<key>NSMotionUsageDescription</key> <string>App需要您的同意,才能访问运动与健身</string>
<!-- 健康更新 -->
<string>App需要您的同意,才能访问健康更新 </string>
<!-- 健康分享 -->
<!-- 蓝牙 -->
<!-- 媒体资料库 -->
<!-- 联系人 -->

android 配置 #


maven { url "" }

0.0.1 #

  • 测试发布.

0.0.2 #

  • 初始化版本.

0.0.2+1 #

  • 更新内嵌工具类版本.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_permissions: ^0.0.2+1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_permissions/flutter_permissions.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.9+1
  • Flutter: 1.17.3

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:flutter_permissions/flutter_permissions.dart]

Package does not support Flutter platform macos

Because of import path [package:flutter_permissions/flutter_permissions.dart]

Package does not support Flutter platform web

Because of import path [package:flutter_permissions/flutter_permissions.dart]

Package does not support Flutter platform windows

Because of import path [package:flutter_permissions/flutter_permissions.dart]

Package not compatible with SDK dart

because of import path [flutter_permissions]

Maintenance issues and suggestions

The description contains too many non-ASCII characters. (-20 points)

The site uses English as its primary language. The value of the description field in your package's pubspec.yaml field should primarily contain characters used in English.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_permissions.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Package is getting outdated. (-4.38 points)

The package was last published 54 weeks ago.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.0
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8