flutter_pdf_printer 1.1.0+1

  • Readme
  • Changelog
  • Example
  • Installing
  • 84

description #

A simple PDF printer for Android and iOS.

Currently only works with PDFs, if other files are needed, feel free to create an issue and we'll look at adding it to the plugin.

This library uses platform channels to call native printing functionality. As other platforms become more available we will look at adding them to the platform channels. Native UI is used to print.

How to use #


 flutter_pdf_printer: ^1.0.0+1

to your pubspec.yml

Then Call


This will call the platform channel and will display the pdf file to be printed!

Check out the example for a sample of how to use this library!

0.0.1 #

  • Initial Release

1.0.0 #

  • Add Unit Tests

1.0.0+1 #

  • longer description

1.0.0+2 #

  • Better description

1.1.0 #

  • Transition to print by base64 bytes so a file on disk isn't required


flutter_pdf_printer_example #

Demonstrates how to use the flutter_pdf_printer plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_pdf_printer: ^1.1.0+1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_pdf_printer/flutter_pdf_printer.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 25, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies