flutter_paycards 0.1.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 52

flutter_paycards #

pub package

This is a Flutter plugin for PayCards SDK.

Work in progress ⏳

*This plugin requires AndroidX migration in Android.

*Currently not working on IOS simulator.

Usage #

import 'package:flutter_paycards/flutter_paycards.dart';
...
Map<dynamic, dynamic> results = await FlutterPaycards.startRecognizer;

0.1.1 #

  • Generated universal ios framework

0.1.0 #

  • Ready for both IOS and Android

example/README.md

flutter_paycards_example #

Demonstrates how to use the flutter_paycards plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_paycards: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_paycards/flutter_paycards.dart';
  
Version Uploaded Documentation Archive
0.1.1 May 26, 2019 Go to the documentation of flutter_paycards 0.1.1 Download flutter_paycards 0.1.1 archive
0.1.0 May 6, 2019 Go to the documentation of flutter_paycards 0.1.0 Download flutter_paycards 0.1.0 archive
0.0.2 Mar 29, 2019 Go to the documentation of flutter_paycards 0.0.2 Download flutter_paycards 0.0.2 archive
0.0.1 Mar 28, 2019 Go to the documentation of flutter_paycards 0.0.1 Download flutter_paycards 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
15
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
75
Overall:
Weighted score of the above. [more]
52
Learn more about scoring.

We analyzed this package on Jun 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

4 out of 4 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/flutter_paycards.dart.

Run flutter format to format lib/flutter_paycards.dart.

Maintenance issues and suggestions

Support latest dependencies. (-5 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test