Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: flutter_notifications: ^0.0.1
2. Install it
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Jan 14, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.7.0
- pana: 0.13.4
Analysis issues and suggestions
Fix dependencies in
flutter pub upgrade failed with the following output:
ERR: The current Flutter SDK version is 1.12.13+hotfix.5. Because flutter_notifications requires Flutter SDK version ^0.1.2, version solving failed.
Maintenance issues and suggestions
No valid SDK. (-20 points)
The analysis could not detect a valid SDK that can use this package.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
Provide a file named
CHANGELOG.md. (-20 points)
Changelog entries help developers follow the progress of your package. See the example generated by
Homepage URL doesn't exist. (-20 points)
At the time of the analysis the
https://invertase.io/oss/flutter-notifications was unreachable.
The package description is too short. (-20 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
Package is pre-v0.1 release. (-10 points)
While nothing is inherently wrong with versions of
0.0.*, it might mean that the author is still experimenting with the general direction of the API.
|Dart SDK||>=1.19.0 <3.0.0|