flutter_native_webview 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 49

flutter_native_webview #

Flutter Use Native WebView

Getting Started #

Create #

flutter create --template=plugin --org com.sky -i swift -a java flutter_native_webview

Check #

flutter packages pub publish --dry-run

Publish #

flutter packages pub publish

Running #

cd example
flutter run

Configuration #

  • Trying to embed a platform view but the PrerollContext does not support embedding
在iOS工程的info.plist文件中添加键值对key=io.flutter.embedded_views_preview value=YES

Document #

https://flutter.dev/docs/development/packages-and-plugins/developing-packages

0.0.1 #

  • TODO: Describe initial release.

example/README.md

flutter_native_webview_example #

Demonstrates how to use the flutter_native_webview plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_native_webview: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_native_webview/flutter_native_webview.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
9
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
72
Overall:
Weighted score of the above. [more]
49
Learn more about scoring.

We analyzed this package on Dec 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Health suggestions

Format lib/flutter_native_webview.dart.

Run flutter format to format lib/flutter_native_webview.dart.

Maintenance suggestions

The package description is too short. (-18 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test