flutter_native_dialog 0.1.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 79

flutter_native_dialog Pub Build Status

This plugin allows using native dialogs in Android and iOS. It was made specifically for Add2App use cases when just a part of your UI is made in Flutter. In this case, you can't use the built-in dialog system.

If you are not integrating Flutter in your existing app, you are better off using the built-in dialog system from the Flutter library

Usage #

To use this plugin, add flutter_native_dialog as a dependency in your pubspec.yaml file.

Example #

import 'package:flutter_native_dialog/flutter_native_dialog.dart';

final result = await FlutterNativeDialog.showConfirmDialog(
      title: "This is a confirm dialog",
      message: "A message in the dialog",
      positiveButtonText: "OK",
      negativeButtonText: "Cancel",

print(result); // true or false depending on user input

0.1.0 #

  • Refactored code

0.0.1 #

  • Implemented showAlertDialog and showConfirmDialog


flutter_native_dialog_example #

Demonstrates how to use the flutter_native_dialog plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_native_dialog: ^0.1.0

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_native_dialog/flutter_native_dialog.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 21, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Maintenance suggestions

Package is getting outdated.

The package was last published 52 weeks ago.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
meta ^1.1.6 1.1.8
Transitive dependencies
collection 1.14.11 1.14.12
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies