flutter_native_config 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 75

flutter_native_config #

A plugin to access native configuration for both Android and iOS from Flutter.

For some third party integrations, for example Google and Facebook, the API keys are usually stored in the native realm -- namely AndroidManifest.xml and Info.plist -- and there's no way to access these values from Flutter. Until now, that it :)

This plugin allows you to access those values directly from Flutter so you don't have to include then in Dart code in addition to the native realm.

Usage #

Import package:flutter_native_config/flutter_native_config.dart, and use the public function FlutterNativeConfig.getConfig() to retrieve a value from both Android and iOS. Because most of the time the key names are different for these two platforms, the function accepts a separate key for each platform.

Example:

import 'package:flutter_native_config/flutter_native_config.dart';

Future<String> get appId {
  return FlutterNativeConfig.getConfig<String>(
    android: 'version_name',
    ios: 'CFBundleName',
  );
}

Future<String> get appVersion {
  return FlutterNativeConfig.getConfig<String>(
    android: 'version_code',
    ios: 'CFBundleShortVersionString',
  );
}

Future.wait([appId, appVersion]).then((result) {
  print('App: ${result[0]} v${result[1]}');
});

Issues #

For reporting bugs, incompatibilities, or feature requests, please submit a new issue.

Contributing #

If you wish to contribute a fix or a new feature, please submit a pr.

License #

This plugin is released under the MIT license.

1.0.0 #

  • Initial release with an API consisting of a single FlutterNativeConfig.getConfig() function.

example/lib/main.dart

//
// Copyright (c) 2019 Noor Dawod. All rights reserved.
//
// Permission is hereby granted, free of charge, to any person obtaining a copy
// of this software and associated documentation files (the "Software"), to deal
// in the Software without restriction, including without limitation the rights
// to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
// copies of the Software, and to permit persons to whom the Software is
// furnished to do so, subject to the following conditions:
//
// The above copyright notice and this permission notice shall be included in all
// copies or substantial portions of the Software.
//
// THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
// IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
// FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
// AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
// LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
// OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
// SOFTWARE.
//

import 'dart:async';
import 'dart:core';

import 'package:flutter/material.dart';

import 'package:flutter/services.dart';
import 'package:flutter_native_config/flutter_native_config.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _appId = 'Unknown';
  String _appVersion = '0.0.0';

  @override
  void initState() {
    super.initState();
    retrieveValues();
  }

  @override
  Widget build(BuildContext context) => MaterialApp(
    home: Scaffold(
      appBar: AppBar(
        title: const Text('Plugin example app'),
      ),
      body: Center(
        child: Column(
          children: <Widget>[
            Text('App name: $_appId\n'),
            Text('App version: $_appVersion\n'),
          ],
        ),
      ),
    ),
  );

  Future<void> retrieveValues() async {
    String appId;
    String appVersion;

    try {
      // Assuming that AndroidManigest.xml is setup to include 'version_name' meta-data.
      appId = await FlutterNativeConfig.getConfig(
        android: 'version_name',
        ios: 'CFBundleName',
      );

      // Assuming that AndroidManigest.xml is setup to include 'version_code' meta-data.
      appVersion = await FlutterNativeConfig.getConfig(
        android: 'version_code',
        ios: 'CFBundleShortVersionString',
      );
    } on PlatformException {
      appId = 'Failed to get values.';
    }

    if (mounted) {
      setState(() {
        _appId = appId;
        _appVersion = appVersion;
      });
    }
  }

  Future<String> get appId {
    return FlutterNativeConfig.getConfig<String>(
      android: 'version_name',
      ios: 'CFBundleName',
    );
  }

  Future<String> get appVersion {
    return FlutterNativeConfig.getConfig<String>(
      android: 'version_code',
      ios: 'CFBundleShortVersionString',
    );
  }

  void r() {
    Future.wait([appId, appVersion]).then((result) {
      print('App: ${result[0]} v${result[1]}');
    });
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_native_config: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_native_config/flutter_native_config.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
52
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
96
Overall:
Weighted score of the above. [more]
75
Learn more about scoring.

We analyzed this package on Jul 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:flutter_native_config/flutter_native_config.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:flutter_native_config/flutter_native_config.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:flutter_native_config/flutter_native_config.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:flutter_native_config/flutter_native_config.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [flutter_native_config] that is in a package requiring null.

Health issues and suggestions

Document public APIs. (-1 points)

4 out of 4 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

Package is getting outdated. (-4.11 points)

The package was last published 54 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test