flutter_multiselect 0.4.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 93

flutter_multiselect #

Flutter package for multi-select UI widget

pub package

Getting Started #

  • Add the package into pubspec.yaml
dependencies:
  flutter_multiselect: 0.0.1
  • Import in your code
import 'package:flutter_multiselect/flutter_multiselect.dart';

Why? #

By default, there is no UI control for multi-select in iOS and Android, and my widget can be used to bridge this gap.

Example #

child: MultiSelect(
  autovalidate: false,
  titleText: title,
  validator: (value) {
    if (value == null) {
      return 'Please select one or more option(s)';
    }
  },
  errorText: 'Please select one or more option(s)',
  dataSource: [
    {
      "display": "Australia",
      "value": 1,
    },
    {
      "display": "Canada",
      "value": 2,
    },
    {
      "display": "India",
      "value": 3,
    },
    {
      "display": "United States",
      "value": 4,
    }
  ],
  textField: 'display',
  valueField: 'value',
  filterable: true,
  required: true,
  value: null,
  onSaved: (value) {
    print('The value is $value');
  }
),

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release. 0.4.0 Aug 22, 2019 - Version 0.4.0 includes minor bug fixes. - added feature to add 'maxLength' to restrict user selecting more than maximum options allowed 0.3.0 Jul 22, 2019 - Version 0.3.0 includes bug fixes. - Restricts the height of selected options in modal to avoid covering the whole screen 0.2.0 Jan 17, 2019 test cases updates & bug fixes 0.1.1 Jan 17, 2019 Fixed formatting issues 0.1.0 Jan 9, 2019 Updated the YAML file with description and version number & updated examples 0.0.2 Dec 6, 2018 * Bug fixes * 0.0.1 Dec 6, 2018 *** Initial Code checkin ***

example/README.md

multiselect_example #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_multiselect: ^0.4.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_multiselect/flutter_multiselect.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
87
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
93
Learn more about scoring.

We analyzed this package on Oct 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-0.00 points)

28 out of 29 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/flutter_multiselect.dart.

Run flutter format to format lib/flutter_multiselect.dart.

Format lib/selection_modal.dart.

Run flutter format to format lib/selection_modal.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test
mockito ^4.0.0