flutter_mobx 1.1.0+2

Flutter Android iOS web

Flutter integration for MobX. It provides a set of Observer widgets that automatically rebuild when the tracked observables change.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  flutter_mobx: ^1.1.0+2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_mobx/flutter_mobx.dart';
213
likes
110
pub points
98%
popularity

Publisher

dart.pixelingene.com

Flutter integration for MobX. It provides a set of Observer widgets that automatically rebuild when the tracked observables change.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, mobx

More

Packages that depend on flutter_mobx