flutter_mmkv_cache 0.0.2

flutter_mmkv_cache #

pub package

A cache for Flutter project implement it with mmkv framework. and support expires

Getting Started #

  flutter_mmkv_cache: ^0.0.2

Usage #

import 'package:flutter_mmkv_cache/flutter_mmkv_cache.dart';

/// https://github.com/OpenFlutter/mmkv_flutter

/// ExpiredCache

/// add value to cache will expired in 1 hour
final boolRes = await ExpiredCache.add('key', 'value', expired: 1  );

/// get value from cache
final value = await ExpiredCache.get('key');

Licenses #

Original License https://github.com/OpenFlutter/mmkv_flutter

0.0.1 #

  • TODO: Describe initial release.


flutter_mmkv_cache_example #

Demonstrates how to use the flutter_mmkv_cache plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_mmkv_cache: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_mmkv_cache/flutter_mmkv_cache.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Feb 25, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Package is getting outdated. (-8.77 points)

The package was last published 56 weeks ago.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8