flutter_mediator_lite 1.0.3
flutter_mediator_lite: ^1.0.3 copied to clipboard

A super easy state management package, base on the InheritedModel with automatic aspect management.

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add flutter_mediator_lite

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  flutter_mediator_lite: ^1.0.3

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:flutter_mediator_lite/mediator.dart';
import 'package:flutter_mediator_lite/mediator/assert.dart';
import 'package:flutter_mediator_lite/mediator/global.dart';
import 'package:flutter_mediator_lite/mediator/host.dart';
import 'package:flutter_mediator_lite/mediator/rx/rx.dart';
import 'package:flutter_mediator_lite/mediator/rx/rx_impl.dart';
import 'package:flutter_mediator_lite/mediator/subscriber.dart';
2
likes
130
pub points
2%
popularity

A super easy state management package, base on the InheritedModel with automatic aspect management.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

rob333.2005@gmail.com

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_mediator_lite