flutter_lock_screen 1.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 89

Flutter Pass Code Page or Pin Code Page Package #

This package gives you beautiful pass code page for using both android and ios.

flutter platform pub package License: MIT

Demo #

Usage #

It is really easy to use! You should ensure that you add the flutter_lock_screen as a dependency in your flutter project.

dependencies:
  flutter_lock_screen: '^1.0.0'

Than you can use it with below examples.

import 'package:flutter/material.dart';
import 'package:flutter_lock_screen/flutter_lock_screen.dart';

class PassCodeScreen extends StatefulWidget {
  PassCodeScreen({Key key, this.title}) : super(key: key);

  final String title;

  @override
  _PassCodeScreenState createState() => new _PassCodeScreenState();
}

class _PassCodeScreenState extends State<PassCodeScreen> {
  @override
  Widget build(BuildContext context) {
    var myPass = [1, 2, 3, 4];
    return LockScreen(
        title: "This is Screet",
        passLength: myPass.length,
        bgImage: "images/pass_code_bg.jpg",
        showFingerPass: false,
        fingerFunction: () => print("dede"),
        borderColor: Colors.white,
        showWrongPassDialog: true,
        wrongPassContent: "Wrong pass please try again.",
        wrongPassTitle: "Opps!",
        wrongPassCancelButtonText: "Cancel",
        passCodeVerify: (List<int> passcode) async {
          for (int i = 0; i < myPass.length; i++) {
            if (passcode[i] != myPass[i]) {
              return false;
            }
          }
          return true;
        },
        onSuccess: () {
          Navigator.of(context).pushReplacement(
              new MaterialPageRoute(builder: (BuildContext context) {
            return null;
          }));
        });
  }
}


Contributing #

Pull requests are welcome. For major changes, please open an issue first to discuss what you would like to change.

Please make sure to update tests as appropriate.

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:flutter_lock_screen/flutter_lock_screen.dart';

class PassCodeScreen extends StatefulWidget {
  PassCodeScreen({Key key, this.title}) : super(key: key);

  final String title;

  @override
  _PassCodeScreenState createState() => new _PassCodeScreenState();
}

class _PassCodeScreenState extends State<PassCodeScreen> {
  @override
  Widget build(BuildContext context) {
    var myPass = [1, 2, 3, 4];
    return LockScreen(
        title: "This is Screet",
        passLength: myPass.length,
        bgImage: "images/pass_code_bg.jpg",
        showFingerPass: false,
        fingerFunction: () => print("dede"),
        borderColor: Colors.white,
        showWrongPassDialog: false,
        wrongPassContent: "Wrong pass please try again.",
        wrongPassTitle: "Opps!",
        wrongPassCancelButtonText: "Cancel",
        passCodeVerify: (List<int> passcode) async {
          for (int i = 0; i < myPass.length; i++) {
            if (passcode[i] != myPass[i]) {
              return false;
            }
          }
          return true;
        },
        onSuccess: () {
          Navigator.of(context).pushReplacement(
              new MaterialPageRoute(builder: (BuildContext context) {
            return null;
          }));
        });
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_lock_screen: ^1.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_lock_screen/flutter_lock_screen.dart';
  
Version Uploaded Documentation Archive
1.0.5 Jan 4, 2019 Go to the documentation of flutter_lock_screen 1.0.5 Download flutter_lock_screen 1.0.5 archive
1.0.4 Jan 3, 2019 Go to the documentation of flutter_lock_screen 1.0.4 Download flutter_lock_screen 1.0.4 archive
1.0.3 Jan 1, 2019 Go to the documentation of flutter_lock_screen 1.0.3 Download flutter_lock_screen 1.0.3 archive
1.0.2 Jan 1, 2019 Go to the documentation of flutter_lock_screen 1.0.2 Download flutter_lock_screen 1.0.2 archive
1.0.1 Jan 1, 2019 Go to the documentation of flutter_lock_screen 1.0.1 Download flutter_lock_screen 1.0.1 archive
1.0.0 Jan 1, 2019 Go to the documentation of flutter_lock_screen 1.0.0 Download flutter_lock_screen 1.0.0 archive
0.0.1 Jan 1, 2019 Go to the documentation of flutter_lock_screen 0.0.1 Download flutter_lock_screen 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
80
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
96
Overall:
Weighted score of the above. [more]
89
Learn more about scoring.

We analyzed this package on May 8, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.0
  • pana: 0.12.15
  • Flutter: 1.5.8

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Update README.md. (-4 points)

2 image links are insecure (e.g. http://www.yasinilhan.com/passcode/howtouse.gif), use https URLs instead.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test