flutter_liquidcore 0.6.0+1

flutter_liquidcore #

Node.js/Javascript virtual machine for Android and iOS in Flutter.

A basic Flutter wrapper for the amazing https://github.com/LiquidPlayer/LiquidCore library.

You should check out the documentation on their Wiki for more information as to how it works.

Features #

  • MicroService integration - A way to communicate with your script/service using an EventEmitter.

  • JsContext integration - A way to execute arbitrary scripts in a self-contained vm.

    It's currently quite limited as it is, it allows you to evaluate scripts and read from them.

    Advanced manipulation of those JsContext objects in Dart isn't currently supported, so they'll need to be done in Javascript.

    There's currently no plans to provide low level object manipulation functionality.

0.0.1 #

  • Initial release!
  • Provides basic MicroService Android integration
  • Partial JsContext integration, simple evaluations can be executed.

0.6.0 #

  • iOS support and bugfixes.
  • Provides full iOS support.
  • Add @flutter_assets/ uri support for the MicroService.
  • LiquidCore bugfixes and improvement.


flutter_liquidcore_example #

Demonstrates how to use the flutter_liquidcore plugin in code.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_liquidcore: ^0.6.0+1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_liquidcore/liquidcore.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Aug 18, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (uuid).


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
uuid ^1.0.0 1.0.3 2.0.2
Transitive dependencies
charcode 1.1.2
collection 1.14.11 1.14.12
convert 2.1.1
crypto 2.1.1+1
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies