flutter_light_plugin 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 44

flutter_light_plugin #

flutter_light_plugin 是一个亮度插件.

android端调节的事当前屏幕亮度,不是系统亮度(因为调节系统亮度需要权限).
ios端调节的是屏幕亮度

相关接口 #

  1. 设置亮度
FlutterLightPlugin.setLight

  1. 获取当前亮度
FlutterLightPlugin.getCurrentLight

  1. 获取系统最大亮度
FlutterLightPlugin.getMaxLight

0.0.1 #

  • TODO: Describe initial release.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:flutter_light_plugin/flutter_light_plugin.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  double light = 0;
  double maxLight = 0;
  String _lightNm;

  @override
  void initState() {
    super.initState();
    FlutterLightPlugin.getMaxLight.then((onValue) {
      print("当前屏幕最大亮度:$onValue");
      maxLight = onValue;
    });
    FlutterLightPlugin.getCurrentLight.then((onValue) {
      print("当前屏幕亮度:$onValue");
      light = onValue;
      setState(() {
        _lightNm="$light";
      });
    });
  }

  void addLight() {
    if(light>maxLight){
      return;
    }
    light=light+0.1*maxLight;
    FlutterLightPlugin.setLight(light);
    setState(() {
      _lightNm="$light";
    });
  }
  void _lessLight() {
    if(light<0){
      return;
    }
    light=light-0.1*maxLight;
    FlutterLightPlugin.setLight(light);
    setState(() {
      _lightNm="$light";
    });
  }
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Center(
          child: Column(
            children: <Widget>[
              Text("当前亮度$_lightNm"),
              FlatButton(
                child: Text("增加亮度"),
                onPressed: () {
                  addLight();
                },
              ),
              FlatButton(
                child: Text("减少亮度"),
                onPressed: () {
                  _lessLight();
                },
              )
            ],
          ),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_light_plugin: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_light_plugin/flutter_light_plugin.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
9
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
44
Learn more about scoring.

We analyzed this package on May 24, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.1
  • pana: 0.13.8-dev
  • Flutter: 1.17.0

Health issues and suggestions

Document public APIs. (-1 points)

6 out of 6 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/flutter_light_plugin.dart.

Run flutter format to format lib/flutter_light_plugin.dart.

Maintenance issues and suggestions

The description contains too many non-ASCII characters. (-20 points)

The site uses English as its primary language. The value of the description field in your package's pubspec.yaml field should primarily contain characters used in English.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test