flutter_libserialport 0.4.0 copy "flutter_libserialport: ^0.4.0" to clipboard
flutter_libserialport: ^0.4.0 copied to clipboard

A simple wrapper around libserialport utilizing Flutter's build system to build and deploy the C-library for the target platform.

0.4.0 #

  • Upgrade libserialport sources to 0.1.1
  • Fix TERMIOX definition

0.3.0 #

  • Upgrade to Dart 2.17, Flutter 3.0, libserialport 0.3

0.2.3 #

  • Fix linux builds for newer kernels (thanks @sitic)

0.2.2 #

  • Example: add serial device entitlement for macOS.

0.2.1 #

  • Fix build error on Ubuntu 16.04.

0.2.0 #

0.1.1 #

  • Switch from dart_serial_port to libserialport.

0.1.0 #

  • Upgraded SDK constraint & dart_serial_port dependency.

0.0.1 #

  • Initial release.
121
likes
140
pub points
95%
popularity

Publisher

unverified uploader

A simple wrapper around libserialport utilizing Flutter's build system to build and deploy the C-library for the target platform.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, libserialport

More

Packages that depend on flutter_libserialport