flutter_keepscreenon 0.1.1

flutter_keepscreenon #

pub package

A package can help you to keep the device's screen on programmatically without any permission.

Getting Started #

Installation #

Add this to your pubspec.yaml (or create it):

dependencies:
  flutter_keepscreenon: any

Then run the flutter tooling:

flutter packages get

Example #

try {
  await FlutterKeepscreenon.keepScreenOn(true);
} on PlatformException catch (e) {
  print(e);
}

Details in example/ folder.

CHANGELOG #

[0.1.1]

  • Upgrade kotlin version.

[0.1.0]

  • Add keepScreenOn and mark activateKeepScreenOn and deactivateKeepScreenOn as deprecated.
  • Add docs.

[0.0.3]

  • Upgrade to dart2

[0.0.2+1]

  • Format code

[0.0.2]

  • Update ios platform code

[0.0.1+1]

  • Add license

[0.0.1]

  • Initial release

example/README.md

flutter_keepscreenon_example #

Demonstrates how to use the flutter_keepscreenon plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_keepscreenon: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_keepscreenon/flutter_keepscreenon.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
47
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
73
Learn more about scoring.

We analyzed this package on Jul 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8

Admin