flutter_ipfs_sdk 0.0.3

  • Readme
  • Changelog
  • Installing
  • 49

alt text

flutter_ipfs #

Add IPFS to your flutter project!

Getting Started #

This package is in very early develpoment

Running node only consumes 28mb of ram and the webview maintains 60fps consistantly

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

[0.0.2] - Bug fix

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_ipfs_sdk: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_ipfs_sdk/flutter_ipfs_sdk.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Oct 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/data/api_service.chopper.dart. (-4.89 points)

Analysis of lib/data/api_service.chopper.dart reported 10 hints, including:

line 18 col 28: Avoid using braces in interpolation when not needed.

line 24 col 32: Avoid using braces in interpolation when not needed.

line 30 col 34: Avoid using braces in interpolation when not needed.

line 42 col 28: Avoid using braces in interpolation when not needed.

line 48 col 36: Avoid using braces in interpolation when not needed.

Fix lib/flutter_ipfs_sdk.dart. (-0.50 points)

Analysis of lib/flutter_ipfs_sdk.dart reported 1 hint:

line 3 col 8: Unused import: 'dart:async'.

Format lib/data/api_service.dart.

Run flutter format to format lib/data/api_service.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (chopper).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_ipfs_sdk.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
chopper ^2.4.1 2.5.3 3.0.1
crypto_keys ^0.1.0 0.1.0
flutter 0.0.0
flutter_webview_plugin ^0.3.7 0.3.8
webview_flutter ^0.3.11+4 0.3.15+1
Transitive dependencies
async 2.4.0
built_collection 4.2.2
built_value 6.7.1
charcode 1.1.2
collection 1.14.11 1.14.12
fixnum 0.10.9
http 0.12.0+2
http_parser 3.1.3
logging 0.11.3+2
matcher 0.12.6
meta 1.1.7
path 1.6.4
pedantic 1.8.0+1
pointycastle 1.0.1
quiver 2.0.5
sky_engine 0.0.99
source_span 1.5.5
stack_trace 1.9.3
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
build_runner any
chopper_generator ^2.3.4