flutter_install_app_plugin 0.2.0

flutter_install_app_plugin #

A Flutter plug-in helps to install iOS and Android apps.

Usage #

It is not uncommon that you may want to ask a user to install another app within your app. What you need to do here is to prepare a set of iOS app ID on App Store, and Android package name.

For example, if you want to lead your customers to install KKBOX, you need to create an app set like:

    var app = AppSet();
    app.iosAppId = 300915900;
    app.androidPackageName = 'com.skysoft.kkbox.android';

Then call the plug-in.

    FlutterInstallAppPlugin.installApp(app);

On iOS, the plug-in calls SKStoreProductViewController, while it creates an activity to open a "market://" URL on Android.

That's all. Enjoy!

0.2.0 #

  • Upgrade build settings for Android.

0.1.2 #

  • Upgrade build settings for Android.

0.1.1 #

  • Clean undesired files.

0.1.0 #

  • The first release.

example/README.md

flutter_install_app_plugin_example #

Demonstrates how to use the flutter_install_app_plugin plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_install_app_plugin: ^0.2.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_install_app_plugin/flutter_install_app_plugin.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
59
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
80
Learn more about scoring.

We analyzed this package on Aug 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8