flutter_image_spotpicker 0.2.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 75

flutter_image_spotpicker #

Tap, put a pin, tap the pin again, remove the pin.

Change Log #

0.2.1 #

Change pin offset to list of maps, fit firebase

0.2.0 #

Change offset to list of double, fit database easier

0.1.1 #

Make pin size constant.

0.1.0 #

Init publish

example/main.dart

import 'package:flutter/material.dart';
import 'package:flutter_image_spotpicker/flutter_image_spotpicker.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  State<StatefulWidget> createState() {
    return ImageSpotpickerExample();
  }
}

class ImageSpotpickerExample extends State<MyApp> {
  static List<Map<String, double>> points = [
    {'x': 178, 'y': 152},
    {'x': 185, 'y': 272},
    {'x': 245, 'y': 186},
  ];

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
        home: Scaffold(
            appBar: AppBar(title: Text("flutter_image_map Example")),
            body: ImageSpotpicker(
              imagePath: 'assets/worldmap.png',
              imageSize: Size(698, 566),
              pins: points,
              isDebug: true,
            )));
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_image_spotpicker: ^0.2.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_image_spotpicker/flutter_image_spotpicker.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
50
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
75
Learn more about scoring.

We analyzed this package on Jul 14, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • flutter_image_spotpicker that is a package requiring null.

Health suggestions

Format lib/src/image_spotpicker.dart.

Run flutter format to format lib/src/image_spotpicker.dart.

Format lib/src/image_spotpicker_painter.dart.

Run flutter format to format lib/src/image_spotpicker_painter.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety