flutter_iconv 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 28

flutter_iconv #

利用ffi调用iconv转换编码 a demo use ffi iconv ffi调用iconv only support android 只有安卓

Getting Started #

gbk to utf8 string #


Future<String> _get4399()async{
  var rep=await http.get("http://www.4399.com");
  var byte=await iconv(rep.bodyBytes,formcode: "gbk",tocode: "utf-8");
  return await utf8.decode(byte);
}

0.0.1 #

  • TODO: Describe initial release.

example/README.md

flutter_iconv_example #

Demonstrates how to use the flutter_iconv plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_iconv: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_iconv/flutter_iconv.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
21
Health:
Code health derived from static analysis. [more]
12
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
28
Learn more about scoring.

We analyzed this package on Jan 16, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health issues and suggestions

Fix lib/flutter_iconv.dart. (-86.72 points)

Analysis of lib/flutter_iconv.dart failed with 7 errors, 1 hint, including:

line 25 col 22: The method 'allocate' isn't defined for the class 'Pointer'.

line 46 col 9: The method 'store' isn't defined for the class 'Pointer'.

line 47 col 9: The method 'store' isn't defined for the class 'Pointer'.

line 51 col 27: The method 'store' isn't defined for the class 'Pointer'.

line 53 col 34: The method 'store' isn't defined for the class 'Pointer'.

Document public APIs. (-1 points)

3 out of 3 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
ffi ^0.1.2 0.1.3
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test