flutter_google_map_polyline_point 0.0.1 copy "flutter_google_map_polyline_point: ^0.0.1" to clipboard
flutter_google_map_polyline_point: ^0.0.1 copied to clipboard

A flutter plugin that decodes encoded google polyline string into list of geo-coordinates suitable for showing route/polyline on maps

flutter_googleMap_polyline_point #

A flutter plugin that decodes encoded google polyline string into list of geo-coordinates suitable for showing route/polyline on maps This package is extension of flutter_polyline_points .

Getting Started #

This package contains functions to decode google encoded polyline string which returns a list of co-ordinates indicating route between two geographical position

Usage #

To use this package, add flutter_googleMap_polyline_point as a dependency in your pubspec.yaml file.

Import the package #

import 'package:flutter_polyline_point/flutter_polyline_point.dart';

First method #

Get the list of points by Geo-coordinate, this return an instance of PolylineResult, which contains the status of the api, the errorMessage, and the list of decoded points.

PolylinePoints polylinePoints = PolylinePoints();
PolylineResult result = await polylinePoints.getRouteBetweenCoordinates(googleAPiKey,
        _originLatitude, _originLongitude, _destLatitude, _destLongitude);
print(result.points);

Second method #

Decode an encoded google polyline string e.g _p~iF~ps|U_ulLnnqC_mqNvxq`@

List<PointLatLng> result = polylinePoints.decodePolyline("_p~iF~ps|U_ulLnnqC_mqNvxq`@");
print(result);

See the example directory for a complete sample app

Hint #

kindly ensure you use a valid google api key,
If you need help generating api key for your project click this link

5
likes
130
pub points
64%
popularity

Publisher

verified publishertesfalemnigussie.com

A flutter plugin that decodes encoded google polyline string into list of geo-coordinates suitable for showing route/polyline on maps

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

flutter, http

More

Packages that depend on flutter_google_map_polyline_point