flutter_flunt 0.1.0+1

  • Readme
  • Changelog
  • Example
  • Installing
  • new59

FlutterFlunt #

Build Status codecov

Library that provides widgets to make it easier to use Flunt-dart in the flutter. See Flunt-dart to use this package.

Usage #

Create a contract #

Create a contract for use in FluntTextFormField.

class NameContract extends Contract<String> {
  NameContract(String value, String name) : super(value, name) {
      isNotEmpty("not should be empty");
      hasMaxLen(40, "should have no more than 40 chars");
      hasMinLen(3, "should have at least 3 chars");
  }
}

Use with FluntTextFormField #

FluntTextFormField extends TextFormField and provides a simple way to use contracts.

  FluntTextFormField(
    contract: (value) => StringContract(value, "Name"),
    decoration: InputDecoration(
    prefixIcon: Icon(Icons.account_circle),
    )
)

0.1.0+1 #

  • Added example.
  • Documentation updates.

0.1.0 #

  • Initial version

example/example.dart

import 'package:flutter/material.dart';
import 'package:flutter_flunt/flutter_flunt.dart';
import 'package:flunt_dart/flunt_dart.dart';

class NameContract extends Contract<String> {
  NameContract(String value, String name) : super(value, name) {
      isNotEmpty("not should be empty");
      hasMaxLen(40, "should have no more than 40 chars");
      hasMinLen(3, "should have at least 3 chars");
  }
}

class FormExample extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
     body: Form(
       child: Column(children: <Widget>[
         FluntTextFormField(
           contract: (String value) => NameContract(value, "Name"),
         ),
       ],)
     ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_flunt: ^0.1.0+1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_flunt/flutter_flunt.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
19
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
59
Learn more about scoring.

We analyzed this package on Nov 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

15 out of 15 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flunt_dart ^0.4.0 0.4.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test