flutter_firebase_auth_ui 0.0.2-alpha

  • Readme
  • Changelog
  • Installing
  • 73

flutter_firebase_auth_ui #

This project will help you build simple and light UI to sign-in users. No big dependencies!

/!\ This library is used in some of my apps and it will be updated as and when needed :) PR are welcome!

Sign-in button list #

This package doesn't (yet) include simple buttons to sign-in users. I will advise you to use flutter_signin_button.

// Google Auth
SignInButton(Buttons.Google, onPressed: _signInWithGoogle)
// Email
SignInButtonBuilder(
  icon: Icons.email,
  text: 'Sign-in with email',
  onPressed: _signInWithEmail,
  backgroundColor: Colors.blueGrey[700],
)
// Phone
SignInButtonBuilder(
  icon: Icons.phone,
  text: 'Sign-in with phone',
  onPressed: _signInWithPhone,
  backgroundColor: Colors.blueGrey[700],
)

Google Auth #

Requires firebase_auth. Please follow the installation instructions. Does NOT requires this plugin, as the UI is part of the firebase_auth plugin.

Future<FirebaseUser> _signInWithGoogle() async {
  final GoogleSignInAccount googleUser = await _googleSignIn.signIn();
  if (googleUser != null) {
    final GoogleSignInAuthentication googleAuth = await googleUser.authentication;
    final AuthCredential credential = GoogleAuthProvider.getCredential(
      accessToken: googleAuth.accessToken,
      idToken: googleAuth.idToken,
    );
    AuthResult result = await _auth.signInWithCredential(credential);
    return result?.user;
  }
  return null;
}

Phone #

void _signInWithPhone() {
  showDialog(
    context: context,
    builder: (context) {
      return SignInPhonePage(onLoggedIn: (authResult) {
        Navigator.of(context).pop();
      });
    },
  );
}

Email #

void _signInWithEmail() {
  showDialog(
    context: context,
    builder: (context) {
      return SignInEmailPasswordPage(onLoggedIn: (authResult) {
        Navigator.of(context).pop();
      });
    },
  );
}

[0.0.2-alpha] - Development in progress

  • Translation in English and French
  • Only Phone / Email+Password included

[0.0.1] - Development in progress

  • Translation in English is not done yet
  • Only Phone / Email+Password included

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_firebase_auth_ui: ^0.0.2-alpha

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_firebase_auth_ui/flutter_firebase_auth_ui.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
58
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
73
Overall:
Weighted score of the above. [more]
73
Learn more about scoring.

We analyzed this package on Oct 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/src/signin_email_password_page.dart. (-0.50 points)

Analysis of lib/src/signin_email_password_page.dart reported 1 hint:

line 63 col 10: The value of the field '_errorMessage' isn't used.

Fix lib/src/signin_phone_page.dart. (-0.50 points)

Analysis of lib/src/signin_phone_page.dart reported 1 hint:

line 29 col 10: The value of the field '_errorMessage' isn't used.

Format lib/generated/i18n.dart.

Run flutter format to format lib/generated/i18n.dart.

Format lib/src/typedef.dart.

Run flutter format to format lib/src/typedef.dart.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_firebase_auth_ui.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Package is pre-release. (-5 points)

Pre-release versions should be used with caution; their API can change in breaking ways.

The package description is too short. (-2 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0
firebase_auth ^0.14.0 0.14.0+5
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
firebase_core 0.4.0+9
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test