flutter_fetch_widget 0.0.1+1

  • Readme
  • Changelog
  • Example
  • Installing
  • 31

flutter_fetch_widget #

Make simple http requests with a Flutter widget.

Features #

  • Uses package http for requests
  • Allows to transform response to a data model
  • supports GET/POST methods

Getting started #

Here is a quick look at using the fetch widget:

// import 'dart:convert' as convert;
// import 'package:http/http.dart' as http;

  url: "https://jsonplaceholder.typicode.com/posts/1",
  transform: _toPost,
  builder: (model) {
    if (model.isWaiting) {
      return Text('Loading...');

    if (model.isDone && model.statusCode != 200) {
      return Text(
        'Could not connect to API service. `${model.response.body}`');

    return Column(
      children: <Widget>[
Post _toPost(http.Response response) {
  final json = convert.json.decode(response.body);
  return Post(json['id'], json['title']);

Acknowledgements #

This was inspired by https://github.com/tkh44/holen

[0.0.1] - TODO: Add release date. #

  • TODO: Describe initial release.


import 'dart:convert' as convert;

import 'package:flutter/material.dart';
import 'package:flutter_fetch_widget/flutter_fetch_widget.dart';

void main() => runApp(new MyApp());

class MyApp extends StatelessWidget {
  Widget build(BuildContext context) {
    return new MaterialApp(
      title: 'Flutter Demo',
      theme: new ThemeData(
        primarySwatch: Colors.blue,
      home: new MyHomePage(title: 'Flutter Demo Home Page'),

class MyHomePage extends StatefulWidget {
  MyHomePage({Key key, this.title}) : super(key: key);

  final String title;

  _MyHomePageState createState() => new _MyHomePageState();

class _MyHomePageState extends State<MyHomePage> {

  Widget build(BuildContext context) {
    return new Scaffold(
      appBar: new AppBar(
        title: new Text(widget.title),
      body: new Center(
        child: new FetchWidget<Post>(
          url: 'https://jsonplaceholder.typicode.com/posts/1',
          transform: _toPost,
          builder: (fetchPost) {
            if (fetchPost.isWaiting) {
              return new Text('Loading...');

            if (fetchPost.isDone && fetchPost.statusCode != 200) {
              return new Text(
                  'Could not connect to API service. `${fetchPost.response.body}`');

            return new Column(
              children: <Widget>[
                new Text('Id: ${fetchPost.data.id}'),
                new Text('Title: ${fetchPost.data.title}'),
                new RaisedButton(
                    color: Colors.green,
                    textColor: Colors.white,
                    onPressed: () => fetchPost.doFetch(),
                    child: new Text('Refresh')),

Post _toPost(response) {
  final Map<String, dynamic> json = convert.json.decode(response.body);
  return new Post(json['id'], json['title']);

class Post {
  final int id;
  final String title;

  Post(this.id, this.title);

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_fetch_widget: ^0.0.1+1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_fetch_widget/flutter_fetch_widget.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Apr 4, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (http).

Package is getting outdated. (-99.73 points)

The package was last published 104 weeks ago.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
http ^0.11.3+16 0.11.3+17 0.12.0+4
Transitive dependencies
async 2.4.1
charcode 1.1.3
collection 1.14.11 1.14.12
http_parser 3.1.4
meta 1.1.8
path 1.6.4
sky_engine 0.0.99
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
test ^0.12.0