flutter_eventemitter 0.1.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 72

eventemitter #

Dependency free publish/subscribe(pub/sub) for dart&flutter.

How to use #

Open the pubspec.yaml file, and add eventemitter: unde dependencies:

  dependencies:
    flutter:
      sdk: flutter
    # ...
    # ...
    eventemitter: ^0.1.3

install it from terminal: Run flutter packages get

Example #

String token = EventEmitter.subscribe('topic', (data) {
  // receive 2
  print(data);
});

// publish is async function
EventEmitter.publish('topic', 1)
EventEmitter.publishSync('topic', 2)
EventEmitter.unsubscribe(token);

[0.1.0] - 2018-11-21 #

  • initial

[0.1.1] - 2018-11-22 #

  • factory readme doc

example/main.dart

import 'package:flutter_eventemitter/flutter_eventemitter.dart';

void main() {
  const MESSAGE = '___message__';

  EventEmitter.subscribe(MESSAGE, (data) {
    // will receive 1 and 2
    // todo: something
  });

  EventEmitter.subscribeOnce(MESSAGE, (data) {
    // will receive 1
    // todo: something
  });

  EventEmitter.publishSync(MESSAGE, 1);
  EventEmitter.publishSync(MESSAGE, 2);

  // remove subscriber
  EventEmitter.clear(MESSAGE);

  subscriber(data) {}

  String token = EventEmitter.subscribe(MESSAGE, subscriber);
  EventEmitter.unsubscribe(token);
  EventEmitter.unsubscribe(subscriber);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_eventemitter: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_eventemitter/flutter_eventemitter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
70
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
37
Overall:
Weighted score of the above. [more]
72
Learn more about scoring.

We analyzed this package on Jul 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

because of import path [flutter_eventemitter] that is in a package requiring null.

Health issues and suggestions

Document public APIs. (-1 points)

14 out of 14 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/flutter_eventemitter.dart.

Run flutter format to format lib/flutter_eventemitter.dart.

Maintenance suggestions

Package is getting outdated. (-62.74 points)

The package was last published 84 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test