flutter_encrypt_lib 1.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 51

flutter_encrypt_lib #

A new flutter plugin project for DES encrypt.

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Note #

publish需要终端代理(在terminal输入export http_proxy=socks5:ip,export https_proxy=socks5:ip仍无效) shadowsocks + proxifier

proxifier:(1)Proxies add address + port + SOCKS Version 5 (2)Rules Localhost->Target Hosts add address or ip

flutter packages pub publish -v

1.0.0 #

  • DES加密(ios,android)

1.0.1 #

  • 增加android

example/lib/main.dart

import 'dart:convert';

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:flutter_encrypt_lib/flutter_encrypt_lib.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _platformVersion = 'Unknown';
  static const platform = const MethodChannel('com.encrypt');
  @override
  void initState() {
    super.initState();
    getDesStr();
  }


  void getDesStr() async {
    String result = "";

    try {
      result = await platform.invokeMethod('getDES', <String, dynamic>{
        'beforeDES': 'android',
        'key':'abcdefgh',
      });
    } on PlatformException catch (e) {

    }
    print("result = $result");
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Center(
          child: Text('Running on: $_platformVersion\n'),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_encrypt_lib: ^1.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_encrypt_lib/flutter_encrypt_lib.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
18
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
62
Overall:
Weighted score of the above. [more]
51
Learn more about scoring.

We analyzed this package on Jul 7, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:flutter_encrypt_lib/flutter_encrypt_lib.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:flutter_encrypt_lib/flutter_encrypt_lib.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:flutter_encrypt_lib/flutter_encrypt_lib.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:flutter_encrypt_lib/flutter_encrypt_lib.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [flutter_encrypt_lib] that is in a package requiring null.

Health suggestions

Fix lib/src/des_encrypt.dart. (-1 points)

Analysis of lib/src/des_encrypt.dart reported 2 hints:

line 1 col 8: Unused import: 'package:flutter/material.dart'.

line 18 col 35: The exception variable 'e' isn't used, so the 'catch' clause can be removed.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/juggist/flutter_encrypt_lib was unreachable.

The package description is too short. (-15 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is getting outdated. (-3.01 points)

The package was last published 53 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test