flutter_draw 1.1.0

  • Readme
  • Changelog
  • Installing
  • 76

Flutter Draw #

A beautiful drawing view for a your flutter application with single line of code.

To start with this, we need to simply add the dependencies in the gradle file of our app module like this

Don't forget to star ⭐ the repo it motivates me to share more open source

Installation #

First, add flutter_draw: as a dependency in your pubspec.yaml file.

Import

import 'package:flutter_draw/flutter_draw.dart';

iOS #

Add the following keys to your Info.plist file, located in <project root>/ios/Runner/Info.plist:

  • NSPhotoLibraryUsageDescription - describe why your app needs permission for the photo library. This is called Privacy - Photo Library Usage Description in the visual editor.
  • NSCameraUsageDescription - describe why your app needs access to the camera. This is called Privacy - Camera Usage Description in the visual editor.
  • NSMicrophoneUsageDescription - describe why your app needs access to the microphone, if you intend to record videos. This is called Privacy - Microphone Usage Description in the visual editor.

Or in text format add the key:

<key>NSPhotoLibraryUsageDescription</key>
<string>Used to demonstrate image picker plugin</string>
<key>NSCameraUsageDescription</key>
<string>Used to demonstrate image picker plugin</string>
<key>NSMicrophoneUsageDescription</key>
<string>Used to capture audio for image picker plugin</string>

Android #

No configuration required - the plugin should work out of the box.

draw

Add this function to Your StateFull Widget Check the Example

 File _drawImage;
 Future<void> getDrawing()  {
    final getDraw =   Navigator.push(context, MaterialPageRoute(
        builder: (context){
          return HomePage();
        }
    )).then((getDraw){
      if(getDraw != null){
        setState(() {
          _drawImage =  getDraw;
        });
      }
    }).catchError((er){print(er);});

  }

Developed By #

Special Thanks #

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[0.0.1] - First Release. #

  • A customisable Draw View Package for your Flutter Application for Both Android & IOS

[1.0.0] - Maintenance Updates. #

  • Maintenance updated, Health Suggestions followed

[1.1.0] - Maintenance Updates. #

  • Bug Fixes

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_draw: ^1.1.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_draw/flutter_draw.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
56
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
76
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform android

Because:

  • package:flutter_draw/flutter_draw.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_linux/path_provider_linux.dart that declares support for platforms: linux

Package does not support Flutter platform ios

Because:

  • package:flutter_draw/flutter_draw.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_linux/path_provider_linux.dart that declares support for platforms: linux

Package does not support Flutter platform linux

Because:

  • package:flutter_draw/flutter_draw.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because:

  • package:flutter_draw/flutter_draw.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: android, ios

Package does not support Flutter platform web

Because:

  • package:flutter_draw/flutter_draw.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because:

  • package:flutter_draw/flutter_draw.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: android, ios

Package not compatible with SDK dart

Because:

  • flutter_draw that is a package requiring null.

Health suggestions

Format lib/flutter_draw.dart.

Run flutter format to format lib/flutter_draw.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (permission_handler).

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and flutter_draw.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
dio ^3.0.9 3.0.9
flutter 0.0.0
image_gallery_saver ^1.2.2 1.5.0
path_provider ^1.6.5 1.6.11
permission_handler ^4.2.0+hotfix.3 4.4.0+hotfix.4 5.0.1+1
random_string ^2.0.1 2.1.0
Transitive dependencies
charcode 1.1.3
collection 1.14.12 1.14.13
file 5.2.1
http_parser 3.1.4
intl 0.16.1
meta 1.1.8 1.2.1
path 1.7.0
path_provider_linux 0.0.1+2
path_provider_macos 0.0.4+3
path_provider_platform_interface 1.0.2
permission_handler_platform_interface 1.0.0 2.0.1
platform 2.2.1
plugin_platform_interface 1.0.2
process 3.0.13
sky_engine 0.0.99
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
xdg_directories 0.1.0
Dev dependencies
flutter_test