flutter_dialogflow_web 0.0.1

  • Readme
  • Changelog
  • Installing
  • 9

Dialogflow v1 for Flutter Web. #


A new Flutter package.

Installation #

  • Add this to your package's pubspec.yaml file:
  flutter_dialogflow_web: ^0.0.1
  • You can install packages from the command line: with Flutter:
$ flutter packages get
  • Dialogflow v1 Import it Now in your Dart code, you can use:
 import 'package:flutter_dialogflow_web/flutter_dialogflow_web.dart';

Usage #

Dialogflow v1 #

  • Dialogflow register and create new Agent
  • Copy Api key (Token)
  • Code
  Dialogflow dialogflow = Dialogflow(token: "Your Token");
  AIResponse response = await dialogflow.sendQuery("Your Query");
  • Example
  void Response(query) async {
    Dialogflow dialogflow = Dialogflow(token: "10178f9cb6cf12321asdf4aae75c87cd");
    AIResponse response = await dialogflow.sendQuery(query);

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

[0.0.1] - TODO: 18-05-2019. #

  • The flutter_dialogflow makes it easy to integrate dialogflow

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_dialogflow_web: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_dialogflow_web/flutter_dialogflow_web.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: Because flutter_dialogflow_web depends on flutter_web from git which depends on flutter_web_ui any, flutter_web_ui from hosted is required.
 So, because flutter_dialogflow_web depends on flutter_web_ui from git, version solving failed.

Health suggestions

Format lib/FloatingDialog/buttonfloatingdialog.dart.

Run dartfmt to format lib/FloatingDialog/buttonfloatingdialog.dart.

Format lib/flutter_dialogflow_web.dart.

Run dartfmt to format lib/flutter_dialogflow_web.dart.

Format lib/main.dart.

Run dartfmt to format lib/main.dart.

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Prefer published dependencies. (-100 points)

The source code in a git repository is mutable and could disappear.

Package is getting outdated. (-13.97 points)

The package was last published 59 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_dialogflow_web.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-3 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.3.0-dev.0.1 <3.0.0