flutter_create 1.0.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 50

For creating custom flutter project from template A standalone solution to issue https://github.com/flutter/flutter/issues/15279

Installation #

If you want to use flutter_create on the command line, install it using pub global activate:

> pub global activate flutter_create

To update flutter_create, use the same pub global activate command.

Usage #

> flutter_create -a appname -u template_url

or

> pub global run flutter_create -a appname -u template_url

> cd appname
> flutter pub get
> flutter run

Features and bugs #

Please file feature requests and bugs at the issue tracker.

1.0.3 #

  • fixed error -> platform specific folder not available

1.0.2 #

  • Clarify description II

1.0.1 #

  • Clarify description

1.0.0 #

  • Initial version, created by Stagehand

example/README.md

Usage

flutter_create -a my_awesome_app -u https://github.com/VictorUvarov/provider_architecture_template

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate flutter_create

2. Use it

The package has the following executables:


$ flutter_create

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_create: ^1.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_create/flutter_create.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Jul 3, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Analysis suggestions

Package not compatible with runtime flutter-web on web

Because of the import of dart:io via the import chain package:flutter_create/flutter_create.dartpackage:flutter_create/src/flutter_create_base.dartdart:io

Package not compatible with runtime web

Because of the import of dart:io via the import chain package:flutter_create/flutter_create.dartpackage:flutter_create/src/flutter_create_base.dartdart:io

Health suggestions

Format lib/src/file_repository_extension.dart.

Run dartfmt to format lib/src/file_repository_extension.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
args ^1.5.2 1.6.0
path ^1.6.4 1.7.0
rename ^1.1.9 1.2.0
Transitive dependencies
logger 0.9.1
Dev dependencies
pedantic ^1.8.0
test ^1.6.0