flutter_contacts_plugin 0.0.3

flutter_contacts_plugin #

A Flutter plugin to retrieve and manage contacts on Android and iOS devices.

Usage #

To use this plugin, add flutter_contacts_plugin as a dependency in your pubspec.yaml file.

Make sure you add the following permissions to your Android Manifest:

<uses-permission android:name="android.permission.READ_CONTACTS" />
<uses-permission android:name="android.permission.WRITE_CONTACTS" />

On iOS, make sure to set NSContactsUsageDescription in the Info.plist file

<key>NSContactsUsageDescription</key>
<string>This app requires contacts access to function properly.</string>

Example #

// Import package
import 'package:flutter_contacts_plugin/flutter_contacts_plugin.dart';

// Get all contacts
Iterable<Contact> contacts = await FlutterContactsPlugin.getContacts();

// Get contacts matching a string
Iterable<Contact> johns = await FlutterContactsPlugin.getContacts(query : "john");

// Add a contact
// The contact must have a firstName / lastName to be successfully added
await FlutterContactsPlugin.addContact(newContact);

//Delete a contact
await FlutterContactsPlugin.deleteContact(contact);



0.0.3 - November 10th, 2018 #

  • Fix some bug

0.0.2 - November 10th, 2018 #

  • Use swift 4 for IOS code

0.0.1 - November 10th, 2018 #

  • All contacts can be retrieved
  • Contacts matching a string can be retrieved

example/README.md

flutter_contacts_plugin_example #

Demonstrates how to use the flutter_contacts_plugin plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_contacts_plugin: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_contacts_plugin/flutter_contacts_plugin.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Aug 19, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/flutter_contacts_plugin.dart.

Run flutter format to format lib/flutter_contacts_plugin.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8