flutter_consent 0.0.1

flutter_consent #

Build Status Pub

Consent management in Flutter.

Features and bugs #

Please file feature requests and bugs at the issue tracker.

License #

Licensed under the terms of the Apache 2.0 license, the full version of which can be found in the LICENSE file included in the distribution.

0.0.1 #

  • initial release - allows for testing of linear consent specifications.


flutter_consent_example #

Demonstrates how to use the flutter_consent plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_consent: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_consent/flutter_consent.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Feb 13, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Health suggestions

Format lib/flutter_consent.dart.

Run flutter format to format lib/flutter_consent.dart.

Format lib/src/consent_card.dart.

Run flutter format to format lib/src/consent_card.dart.

Format lib/src/consent_specification.dart.

Run flutter format to format lib/src/consent_specification.dart.

Format lib/src/linear_consent_selector.dart.

Run flutter format to format lib/src/linear_consent_selector.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
flutter_radio_slider ^0.0.1 0.0.1
flutter_swiper ^1.1.6 1.1.6
Transitive dependencies
collection 1.14.11 1.14.12
flutter_page_indicator 0.0.3
meta 1.1.8
sky_engine 0.0.99
transformer_page_view 0.1.6
typed_data 1.1.6
vector_math 2.0.8