flutter_compass 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 45

flutter_compass #

A Flutter compass. The heading varies from 0-360, 0 being north.

For IOS: #

Make sure to add NSLocationWhenInUseUsageDescription and NSLocationAlwaysAndWhenInUseUsageDescription keys with appropriate descriptions to the Info.plist file.

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

0.0.1 #

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_compass: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_compass/flutter_compass.dart';
  
Version Uploaded Documentation Archive
0.3.2 Apr 23, 2019 Go to the documentation of flutter_compass 0.3.2 Download flutter_compass 0.3.2 archive
0.2.0 Mar 14, 2019 Go to the documentation of flutter_compass 0.2.0 Download flutter_compass 0.2.0 archive
0.1.0 Dec 14, 2018 Go to the documentation of flutter_compass 0.1.0 Download flutter_compass 0.1.0 archive
0.0.3 Dec 12, 2018 Go to the documentation of flutter_compass 0.0.3 Download flutter_compass 0.0.3 archive
0.0.2 Jul 31, 2018 Go to the documentation of flutter_compass 0.0.2 Download flutter_compass 0.0.2 archive
0.0.1 Jul 30, 2018 Go to the documentation of flutter_compass 0.0.1 Download flutter_compass 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
89
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
45
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0