flutter_clipboard 1.0.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 0

This plugin is discontinued. #

Use the Clipboard Class provided in Flutter itself, instead.

1.0.2 #

  • Plugin Discontinued.

1.0.1 #

  • Fixed Demo APK.
  • Changed Demo GIF

1.0.0 #

  • Initial release.

example/README.md

Flutter Clipboard Example #

Demonstrates how to use the flutter_clipboard plugin.

Complete Example

/// Retrieving Clipboard Text
FlutterClipboard.retrieve.then(
      (clipboardText) {
          print("Clipboard Text: $clipboardText");
      },
);

/// Copying Text To Clipboard
FlutterClipboard.send(text).then(
      (success) {
          if(success)
            print("Successfully copied <$text> to clipboard.");
          else
            print("Couldn't copy <$text> to clipboard.");
      },
);

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_clipboard: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_clipboard/flutter_clipboard.dart';
  
Version Uploaded Documentation Archive
1.0.2 Apr 21, 2019 Go to the documentation of flutter_clipboard 1.0.2 Download flutter_clipboard 1.0.2 archive
1.0.1 Mar 23, 2019 Go to the documentation of flutter_clipboard 1.0.1 Download flutter_clipboard 1.0.1 archive
1.0.0 Mar 21, 2019 Go to the documentation of flutter_clipboard 1.0.0 Download flutter_clipboard 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

This package is not analyzed, because it is discontinued.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0