flutter_chart 0.1.5

Flutter绘制图表,支持 android 和 ios #

绘制曲线,折线,柱状,饼图,包含动画效果和触摸操作

怎么使用? #

  • 添加依赖 flutter_chart: ^0.1.5

我的博客 #

#运行效果

image

0.1.5 - 2019/7/11 #

  • 添加了对图表的触摸手势的支持,另外,柱状图现在支持绘制圆角

0.1.4 - 2019/7/9 #

  • 曲线,折线 添加阴影绘制

0.1.3 - 2019/5/16 #

  • 优化动画

0.1.2 - 2019/4/24 #

  • 添加示例代码

0.1.0 - 2019/4/22 #

  • 修改版本

0.0.1 - 2019/4/22 #

  • 贝塞尔曲线,柱状图

example/README.md

Flutter绘制图表 #

绘制曲线和柱状图,包含动画效果

怎么使用? #

  • 添加依赖 flutter_chart: ^0.0.1

我的博客 #

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_chart: ^0.1.5

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_chart/flutter_chart.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
56
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
76
Learn more about scoring.

We analyzed this package on Aug 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The description is too long. (-10 points)

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test