flutter_chameleon 0.1.4

  • Readme
  • Changelog
  • Installing
  • 0



flutter_chameleon #

Flutter package to show platform dependent widgets.

Usage #

Just use chameleon widgets instead of material or cupertino and they will show up depending on the hosting platform.

Widget included #

  • activity indicator
  • alert dialog
  • bottom navigationbar
  • button
  • dialog
  • slider
  • switch
  • bottomSheet/picker

More to come..

Contributions #

Contributions of any kind are more than welcome! Feel free to fork and improve flutter_chameleon in any way you want, make a pull request, or open an issue.

[0.1.0] #

First release

[0.1.1] #

Critical fix

[0.1.2] #

Minor clean up

[0.1.3] #

Change flatbutton with materialbutton

[0.1.4] #

Added chameleonPicker

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_chameleon: ^0.1.4

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_chameleon/flutter_chameleon.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Feb 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running flutter pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.7.0.
 Because flutter_chameleon requires SDK version >=1.2.0 <=2.0.0, version solving failed.

Health suggestions

Format lib/chameleon_picker.dart.

Run flutter format to format lib/chameleon_picker.dart.

Maintenance issues and suggestions

Support future stable Dart 2 SDKs in pubspec.yaml. (-20 points)

The SDK constraint in pubspec.yaml doesn't allow future stable Dart 2.x SDK releases.

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Package is getting outdated. (-80.82 points)

The package was last published 94 weeks ago.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_chameleon.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.2.0 <=2.0.0