flutter_blue_beacon 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 78

flutter_blue_beacon #

A Bluetooth Low Energy (BLE) beacon implementation native to flutter using the flutter_blue plugin.

Current implementation status:

ProtocolAndroidiOS*
iBeaconYes?
AltBeaconNoNo
EddystoneUIDYes?
EddystoneEIDYes?
EddystoneTLM (Unencrypted)NoNo
EddystoneTLM (Encrypted)NoNo
EddystoneURLNoNo
  • iOS code are not tested, feel free to test it for me and report any problems.
  • I have heard that iBeacon scans on iOS are not possible without using native APIs, if this is true, then iBeacon support for iOS in this library will be impossible since this library conducts low-level BLE scans and then translates it according to beacon protocols.

Feel free to contribute and add support to more protocols!
A good start for implementing Eddystone: https://github.com/evothings/cordova-eddystone
A good start for implementing iBeacon: https://stackoverflow.com/questions/18906988/what-is-the-ibeacon-bluetooth-profile

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[0.0.2] - 2019/03/05

  • Provide support for both EddystoneUID, EddystoneEID and iBeacon, with a redesigned example app.

[0.0.1] - 2019/03/04.

  • Provide support for EddystoneUID only, tested with the example app.

example/README.md

example #

An example of flutter_blue_beacon usage.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_blue_beacon: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_blue_beacon/flutter_blue_beacon.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
66
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
78
Learn more about scoring.

We analyzed this package on Nov 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

44 out of 44 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (flutter_blue).

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
flutter_blue ^0.5.0 0.5.0 0.6.3+1
quiver >=2.0.0 <3.0.0 2.1.2+1
Transitive dependencies
charcode 1.1.2
collection 1.14.11 1.14.12
convert 2.1.1
fixnum 0.10.11
matcher 0.12.6
meta 1.1.7 1.1.8
path 1.6.4
protobuf 0.10.8 1.0.1
sky_engine 0.0.99
stack_trace 1.9.3
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test