flutter_bloc_generator 1.0.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 55

DEPRECATED #

New package found at bloc_generator

Moved to bloc_generator #

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_bloc_generator: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

Version Uploaded Documentation Archive
1.0.0 Jan 1, 2019 Go to the documentation of flutter_bloc_generator 1.0.0 Download flutter_bloc_generator 1.0.0 archive
0.3.0 Dec 31, 2018 Go to the documentation of flutter_bloc_generator 0.3.0 Download flutter_bloc_generator 0.3.0 archive
0.2.6 Nov 21, 2018 Go to the documentation of flutter_bloc_generator 0.2.6 Download flutter_bloc_generator 0.2.6 archive
0.2.5 Nov 11, 2018 Go to the documentation of flutter_bloc_generator 0.2.5 Download flutter_bloc_generator 0.2.5 archive
0.2.4 Nov 10, 2018 Go to the documentation of flutter_bloc_generator 0.2.4 Download flutter_bloc_generator 0.2.4 archive
0.2.3 Nov 9, 2018 Go to the documentation of flutter_bloc_generator 0.2.3 Download flutter_bloc_generator 0.2.3 archive
0.2.2 Nov 9, 2018 Go to the documentation of flutter_bloc_generator 0.2.2 Download flutter_bloc_generator 0.2.2 archive
0.2.1 Nov 9, 2018 Go to the documentation of flutter_bloc_generator 0.2.1 Download flutter_bloc_generator 0.2.1 archive
0.2.0 Nov 7, 2018 Go to the documentation of flutter_bloc_generator 0.2.0 Download flutter_bloc_generator 0.2.0 archive
0.1.9 Nov 7, 2018 Go to the documentation of flutter_bloc_generator 0.1.9 Download flutter_bloc_generator 0.1.9 archive

All 19 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
19
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
55
Learn more about scoring.

We analyzed this package on May 23, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.1
  • pana: 0.12.16

Platforms

Detected platforms: Flutter, web, other

No libraries.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0