New package found at bloc_generator
Moved to bloc_generator #
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: flutter_bloc_generator: ^1.0.0
2. Install it
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on May 24, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.8.1
- pana: 0.13.8-dev
Maintenance issues and suggestions
No valid SDK. (-20 points)
The analysis could not detect a valid SDK that can use this package.
dartdoc successfully runs on your package's source files. (-10 points)
exitCode: 255 stdout: Documenting flutter_bloc_generator... Initialized dartdoc with 37 libraries in 35.4 seconds Validating docs... no issues found Documented 0 public libraries in 7.2 seconds stderr: Unhandled exception: dartdoc could not find any libraries to document #0 Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:196:7)
Package is getting outdated. (-39.18 points)
The package was last published 72 weeks ago.
The package description is too short. (-20 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
|Dart SDK||>=2.0.0 <3.0.0|