flutter_baidu_map 0.0.5

  • README.md
  • Example
  • Installing
  • Versions
  • 73

flutter_baidu_map #



Getting Started #

集成百度地图定位android版本 #

1、先申请一个apikey http://lbsyun.baidu.com/apiconsole/key

2、修改 你的项目目录/app/build.gradleandroid/defaultConfig节点修改manifestPlaceholders,新增百度地图AK配置

android {
    .... 你的代码

    defaultConfig {
         manifestPlaceholders = [
                BAIDU_MAP_KEY : "你的百度地图AK", /// 百度地图AK


集成百度地图定位ios版本 #

1、申请一个key http://lbsyun.baidu.com/apiconsole/key


import 'package:flutter_baidu_map/flutter_baidu_map.dart';
   void main(){     
     runApp(new MyApp());



怎么用 #

先导入dart包 修改pubspec.yaml,增加依赖:

  flutter_baidu_map: ^0.0.5


import 'package:flutter_baidu_map/flutter_baidu_map.dart';


PermissionStatus permission = await PermissionHandler().checkPermissionStatus(PermissionGroup.location);
bool hasPermission = permission == PermissionStatus.granted;
    Map<PermissionGroup, PermissionStatus> map = await PermissionHandler().requestPermissions([
    if(map.values.toList()[0] != PermissionStatus.granted){
BaiduLocation location = await FlutterBaiduMap.getCurrentLocation();

0.0.1 #

  • TODO: Describe initial release.


flutter_baidu_map_example #

Demonstrates how to use the flutter_baidu_map plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_baidu_map: ^0.0.5

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_baidu_map/flutter_baidu_map.dart';
Version Uploaded Documentation Archive
0.0.5 Mar 13, 2019 Go to the documentation of flutter_baidu_map 0.0.5 Download flutter_baidu_map 0.0.5 archive
0.0.4 Mar 13, 2019 Go to the documentation of flutter_baidu_map 0.0.4 Download flutter_baidu_map 0.0.4 archive
0.0.3 Mar 13, 2019 Go to the documentation of flutter_baidu_map 0.0.3 Download flutter_baidu_map 0.0.3 archive
0.0.2 Mar 12, 2019 Go to the documentation of flutter_baidu_map 0.0.2 Download flutter_baidu_map 0.0.2 archive
0.0.1 Mar 12, 2019 Go to the documentation of flutter_baidu_map 0.0.1 Download flutter_baidu_map 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jun 25, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

23 out of 23 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/flutter_baidu_map.dart. (-0.50 points)

Analysis of lib/flutter_baidu_map.dart reported 1 hint:

line 2 col 8: Unused import: 'dart:io'.

Maintenance issues and suggestions

The description contains too many non-ASCII characters. (-20 points)

The site uses English as its primary language. The value of the description field in your package's pubspec.yaml field should primarily contain characters used in English.

Support latest dependencies. (-5 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies