flutter_autofill 0.4.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 86

flutter_autofill #

Provides Android Autofill support for Flutter text fields.

Supports all Android hint types.

Add dependency #

dependencies:
  flutter_autofill: ^0.4.1

Usage #

At its simplest form, you can just wrap your TextField with Autofill widget:

import 'package:flutter_autofill/flutter_autofill.dart';
          Autofill(
                onAutofilled: (val) {
                   // set value in controller & cursor position after auto-filled value
                  _emailController.value = TextEditingValue(text: val, selection: TextSelection.fromPosition(TextPosition(offset: val.length)));
                },
                autofillHints: [FlutterAutofill.AUTOFILL_HINT_EMAIL_ADDRESS],
                autofillType: FlutterAutofill.AUTOFILL_TYPE_TEXT,
                textController: _emailController,
                child: TextField(
                  controller: _emailController,
                  decoration: InputDecoration(hintText: "Please enter your email"),
                ),
              ),

For Autofill to function properly and be available on subsequent visits of screen, you must notify Autofill when data has been submitted or cancelled.

  bool commited = false;

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: const Text('Autofill Widget screen'),
      ),
      body: WillPopScope(
        onWillPop: () async {
          if (!commited) {
            await FlutterAutofill.cancel();
          }
          return true;
        },
        child: ...
  void _onSubmit() async {
    await FlutterAutofill.commit();
    commited = true;
    ...
  }

0.4.2 #

Fixed: cancel() called on null Fixed: Make textController a required argument Fixed: Don't run in background tasks

0.4.1 #

Initial Release

example/lib/main.dart

import 'package:flutter/material.dart';

import 'menu_screen.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(home: MenuScreen());
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_autofill: ^0.4.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_autofill/flutter_autofill.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
73
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
86
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:flutter_autofill/flutter_autofill.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:flutter_autofill/flutter_autofill.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:flutter_autofill/flutter_autofill.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:flutter_autofill/flutter_autofill.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [flutter_autofill] that is in a package requiring null.

Health suggestions

Fix lib/src/flutter_autofill_manager.dart. (-0.50 points)

Analysis of lib/src/flutter_autofill_manager.dart reported 1 hint:

line 125 col 7: 'defaultBinaryMessenger' is deprecated and shouldn't be used. Use ServicesBinding.instance.defaultBinaryMessenger instead. This feature was deprecated after v1.6.5..

Format lib/generated/i18n.dart.

Run flutter format to format lib/generated/i18n.dart.

Format lib/src/flutter_autofill_widget.dart.

Run flutter format to format lib/src/flutter_autofill_widget.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test