flutter_audio_player 0.1.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 67

flutter_audio_player #

Plugin that allow flutter to play a local short sound(30 seconds or less in duration).

Install #

add flutter_audio_player as a dependency in pubspec.yaml

How to use #

  1. add audio file
  2. add asset in pubspec.yaml
  3. you can add audio to player list AudioPlayer.addSound(soundPath);
  4. you can remove all audio in player list AudioPlayer.removeAllSound();

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

0.1.2 #

  • fix doc

0.1.1 #

  • fix doc

0.1.0 #

  • add doc

0.0.1 #

  • init
    • add audio to player list AudioPlayer.addSound(soundPath);
    • remove all audio in player list AudioPlayer.removeAllSound();

example/README.md

audio_player_example #

Demonstrates how to use the audio_player plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_audio_player: ^0.1.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_audio_player/flutter_audio_player.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
35
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
67
Learn more about scoring.

We analyzed this package on Oct 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8