flutter_alpha_vantage_package 0.0.1

  • Readme
  • Changelog
  • Installing
  • 1

flutter_alpha_vantage_package #

A new Flutter package for using alpha vantage api.

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

Usage #

Add the following import statement where you need to use this package libraries: import 'package:flutter_alpha_vantage_package/flutter_alpha_vantage_package.dart';

There are four libraries to use to call Alpha Vantage rest api: TimeSeries.dart, SectorPerformances.dart, ForeignExchange.dart, CryptoCurrencies.dart, and TechnicalIndicators.dart.


import 'package:flutter_alpha_vantage_package/flutter_alpha_vantage_package.dart';
import 'package:test/test.dart';

void main() async {

  test('Intraday', () async {
    final timeSeries = new TimeSeries("YourAlphaVantageAPIKey");
    JSONObject json = await timeSeries.getIntraday("MSFT");

    // Use get method to search entire json for key for stock
    expect(json.get("2. Symbol"), "MSFT");

    // Use map to find stock symbol
    expect(json.getJSONMap()["Meta Data"]["2. Symbol"], "MSFT");

  test('Intraday', () async {
    final technicalIndicator = new TechnicalIndicators("YourAlphaVantageAPIKey");
    JSONObject json = await technicalIndicator.getSMA("MSFT");

    // Use get method to search entire json for key for stock
    expect(json.get("1: Symbol"), "MSFT");

    // Use map to find stock symbol
    expect(json.getJSONMap()["Meta Data"]["1: Symbol"], "MSFT");


  • Inital Release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_alpha_vantage_package: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_alpha_vantage_package/flutter_alpha_vantage_package.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0