flunama 0.0.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 28

flunama #

A flutter package for Mapbox widget. Can create a Maobix map widget for Android and iOS, features are now limited and the package is still under development.

Getting Started #

Android #

  1. Have to add the following line to android/app/build.gradle.

implementation 'com.mapbox.mapboxsdk:mapbox-android-sdk:6.7.2'

  1. Add the following line to MainActivity.java.

Mapbox.getInstance(this, "<--mapbox_token_here-->");

iOS #

  1. Do a pod install in your folder

0.0.3 #

  • Add the ability to set Mapbox access token in code

0.0.2 #

  • Populate the README and add some more info about the package

0.0.1 #

  • Published package
  • Add Android and iOS initial support

example/lib/main.dart

import 'package:flutter/material.dart';

import 'package:flunama/flunama.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  MapBoxController controller;

  @override
  void initState() {
    super.initState();
  }

  void _onMapCreated(MapBoxController controller) {
    this.controller = controller;
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: Text("flunama example"),
          actions: <Widget>[
            FlatButton(
              child: Icon(Icons.gps_fixed),
              onPressed: () {
                controller.setCenterCoordinate(Coordinate(47.5, 19.05), true);
                controller.getStyleURL().then((url) {
                  debugPrint(url);
                });
                controller.setStyleURL(Style.satelliteStreets);
              },
            )
          ],
        ),
        body: MapBox(
          onMapCreated: _onMapCreated,
          options: MapboxOptions(
            "pk.eyJ1IjoiZm9udGluYWxpcyIsImEiOiJjamo3N3QxZzkwcGZkM3Jzd3R0OHd3eG9jIn0.MDmSPZyfbQ7NP0toOzSnyg",
            styleURL: Style.satellite,
            centerCoordinate: Coordinate(42, 47),
            zoomLevel: 3.0,
          ),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flunama: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flunama/flunama.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
74
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
27
Overall:
Weighted score of the above. [more]
28
Learn more about scoring.

We analyzed this package on Mar 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health issues and suggestions

Fix lib/src/mapbox.dart. (-25.38 points)

Analysis of lib/src/mapbox.dart failed with 1 error, 1 hint:

line 12 col 30: 1 positional argument(s) expected, but 0 found.

line 5 col 7: This class (or a class which this class inherits from) is marked as '@immutable', but one or more of its instance fields are not final: MapBox.options

Fix lib/src/controller.dart. (-0.50 points)

Analysis of lib/src/controller.dart reported 1 hint:

line 35 col 13: The value of the field '_id' isn't used.

Fix lib/src/options.dart. (-0.50 points)

Analysis of lib/src/options.dart reported 1 hint:

line 10 col 5: Redundant use of the annotation @required on the required positional parameter 'accessToken'.

Format lib/flunama.dart.

Run flutter format to format lib/flunama.dart.

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Package is getting outdated. (-23.29 points)

The package was last published 64 weeks ago.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8