fluid_slider 1.0.1

  • Readme
  • Changelog
  • Installing
  • 62

Flutter - Fluid Slider #

If this project has helped you out, please support us with a star. 🌟

Preview #

Alt Text

Getting Started #

dependencies:
	...
	fluid_slider: ^1.0.0

Usage Example #

Adding the widget

import 'package:fluid_slider/fluid_slider.dart';

FluidSlider(
  min: 0,
  max: 100,
  sliderColor: Colors.indigo,
  textColor: Colors.white,
  onValue: (value) => {},
  onSlide: (value) => {},
)

Slider Properties #

PropertyTypeRequiredDefault Value
minintYes--
maxintYes--
sliderColorColorNoColors.indigo
textColorColorNoColors.indigo
onValueFunctionYes--
onSlideFunctionNo--

[1.0.0] - TODO: Add release date.

  • Added Basic Version of Slider

[1.0.1] - TODO: Update Broken Md file.

  • Updated Markdown File

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fluid_slider: ^1.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fluid_slider/fluid_slider.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
28
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
62
Learn more about scoring.

We analyzed this package on Oct 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/fluid_slider.dart.

Run flutter format to format lib/fluid_slider.dart.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and fluid_slider.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test