floating_search_bar 0.2.0

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 93

floating_search_bar #

A Search App Bar like the one in Gmail and Google Photos.

Getting Started #

If you want to just use the floating bar as an app bar please use SliverFloatingBar otherwise use FloatingSearchBar.

search

if you add a drawer the menu icon will show up:

drawer

Usage #

import 'package:flutter/material.dart';

import 'package:floating_search_bar/floating_search_bar.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: FloatingSearchBar.builder(
        itemCount: 100,
        itemBuilder: (BuildContext context, int index) {
          return ListTile(
            leading: Text(index.toString()),
          );
        },
        trailing: CircleAvatar(
          child: Text("RD"),
        ),
        drawer: Drawer(
          child: Container(),
        ),
        onChanged: (String value) {},
        onTap: () {},
        decoration: InputDecoration.collapsed(
          hintText: "Search...",
        ),
      ),
    );
  }
}

0.2.0 - 04.06.2019 #

  • Updating Example to be desktop aware

0.1.3 #

  • Fixing automaticallyImplyLeading

0.1.2 #

  • Support for End Drawer

0.1.1 #

  • Added App Bar

example/README.md

floating_search_bar_example #

Demonstrates how to use the floating_search_bar plugin.

import 'package:flutter/material.dart';

import 'package:floating_search_bar/floating_search_bar.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: FloatingSearchBar.builder(
        itemCount: 100,
        itemBuilder: (BuildContext context, int index) {
          return ListTile(
            leading: Text(index.toString()),
          );
        },
        trailing: CircleAvatar(
          child: Text("RD"),
        ),
        drawer: Drawer(
          child: Container(),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  floating_search_bar: ^0.2.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:floating_search_bar/floating_search_bar.dart';
  
Version Uploaded Documentation Archive
0.2.0 Apr 6, 2019 Go to the documentation of floating_search_bar 0.2.0 Download floating_search_bar 0.2.0 archive
0.1.3 Mar 14, 2019 Go to the documentation of floating_search_bar 0.1.3 Download floating_search_bar 0.1.3 archive
0.1.2 Mar 13, 2019 Go to the documentation of floating_search_bar 0.1.2 Download floating_search_bar 0.1.2 archive
0.1.1 Mar 13, 2019 Go to the documentation of floating_search_bar 0.1.1 Download floating_search_bar 0.1.1 archive
0.1.0 Mar 13, 2019 Go to the documentation of floating_search_bar 0.1.0 Download floating_search_bar 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
88
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
92
Overall:
Weighted score of the above. [more]
93
Learn more about scoring.

We analyzed this package on Jun 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

Support latest dependencies. (-5 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency.

The package description is too short. (-3 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test