floating_menu 0.1.0+hotfix.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 84

floating_menu #

This package will give you animated button(s) when clicked with the shape you want with multiple nice animation.

Check the demo app in example directory.

Right Vertical Straight Floating Menu

vertical floating menu

Right to Left Horizontal Straight Floating Menu

horizontal floating menu

Right Curved Circular Floating Menu

circular curved floating menu

Right to Left Curvy Floating Menu

curved floating menu

Bottom Center Circular Floating Menu

circular floating menu

[0.1.0+hotfix.1] - Floating menu buttons made clickable

  • Menu child buttons not clickable issue fixed.
  • Now it is possible to center floating menu.

[0.1.0] - Floating menu for any device

  • Basic animation.
  • Change the curve to any shape using locationDegree.
  • Change the distance of buttons using locationDistance.

example/lib/main.dart

import 'package:floating_menu/floating_menu.dart';
import 'package:flutter/material.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  // This widget is the root of your application.
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Flutter Demo',
      theme: ThemeData(
        // This is the theme of your application.
        //
        // Try running your application with "flutter run". You'll see the
        // application has a blue toolbar. Then, without quitting the app, try
        // changing the primarySwatch below to Colors.green and then invoke
        // "hot reload" (press "r" in the console where you ran "flutter run",
        // or simply save your changes to "hot reload" in a Flutter IDE).
        // Notice that the counter didn't reset back to zero; the application
        // is not restarted.
        primarySwatch: Colors.blue,
      ),
      home: MyHomePage(title: 'Flutter Demo Home Page'),
    );
  }
}

class MyHomePage extends StatefulWidget {
  MyHomePage({Key key, this.title}) : super(key: key);

  // This widget is the home page of your application. It is stateful, meaning
  // that it has a State object (defined below) that contains fields that affect
  // how it looks.

  // This class is the configuration for the state. It holds the values (in this
  // case the title) provided by the parent (in this case the App widget) and
  // used by the build method of the State. Fields in a Widget subclass are
  // always marked "final".

  final String title;

  @override
  _MyHomePageState createState() => _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text(widget.title),
      ),
      body: SizedBox(),
      floatingActionButton: FloatingMenu(
        isMainButton: true,
        mainButtonColor: Colors.red,
        mainButtonIcon: Icons.file_upload,
        mainButtonShape: BoxShape.circle,
        floatingType: FloatingType.RightCurve,
        floatingButtonShape: BoxShape.circle,
        floatingButtons: [
          FloatingButtonModel(
            locationDegree: 270,
            locationDistance: 70,
            shape: BoxShape.circle,
            color: Colors.greenAccent,
            label: "Audio",
            icon: Icons.audiotrack,
            size: Size(45, 45),
            onPress: () {
              print("Audio");
            },
          ),
          FloatingButtonModel(
            locationDegree: 270,
            locationDistance: 130,
            shape: BoxShape.circle,
            color: Colors.yellowAccent,
            label: "File",
            icon: Icons.insert_drive_file,
            size: Size(45, 45),
            onPress: () {
              print("File");
            },
          ),
          FloatingButtonModel(
            locationDegree: 270,
            locationDistance: 190,
            shape: BoxShape.circle,
            color: Colors.purpleAccent,
            label: "Image",
            icon: Icons.image,
            size: Size(45, 45),
            onPress: () {
              print("Image");
            },
          ),
          FloatingButtonModel(
            locationDegree: 270,
            locationDistance: 250,
            shape: BoxShape.circle,
            color: Colors.orangeAccent,
            label: "Video",
            icon: Icons.music_video,
            size: Size(45, 45),
            onPress: () {
              print("video");
            },
          ),
        ],
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  floating_menu: ^0.1.0+hotfix.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:floating_menu/floating_menu.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
68
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
84
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • floating_menu that is a package requiring null.

Health suggestions

Format lib/floating_menu.dart.

Run flutter format to format lib/floating_menu.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.5.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test